IS-IS Lab2 – Configuring IS-IS Multi Area and Summary Route

Ensurepass

Objectives

1. To master the basic routing protocol configuration.

2. To understand the type of L1/L2 route.

3. To master the summary configuration of IS-IS area.

Lab Topology

14

Lab Steps

1. Configure the router’s IP address, and use the command Ping to confirm the connect’s interoperability of each router.

2. The configuration of each router is shown as below:

R1(config)#interface Loopback0

R1(config-if)#ip address 172.16.1.1 255.255.255.0

R1(config-if)#ip router isis cisco

R1(config-if)#isis circuit-type level-1

R1(config-if)#exit

R1(config)#

R1(config)#interface Loopback1

R1(config-if)#ip address 172.16.2.1 255.255.255.0

R1(config-if)#ip router isis cisco

R1(config-if)#isis circuit-type level-1

R1(config-if)#exit

R1(config)#

R1(config)#interface Serial1/1

R1(config-if)#ip address 172.16.255.1 255.255.255.252

R1(config-if)#ip router isis cisco

R1(config-if)#isis circuit-type level-2-only

R1(config-if)#exit

R1(config)#

R1(config)#router isis cisco

R1(config-if)#net 49.0001.ca00.0bbc.0000.00

R1(config-if)#exit

R2(config)#interface Serial1/0

R2(config-if)#ip address 172.16.255.2 255.255.255.252

R2(config-if)#ip router isis cisco

R2(config-if)#isis circuit-type level-2-only

R2(config-if)#exit

R2(config)#

R2(config)#interface Serial1/1

R2(config-if)#ip address 172.16.255.5 255.255.255.252

R2(config-if)#ip router isis cisco

R2(config-if)#exit

R2(config)#

R2(config)#router isis cisco

R2(config-if)#net 49.0002.ca01.0bbc.0000.00

R2(config-if)#exit

R2(config)#

R3(config)#interface Serial1/0

R3(config-if)#ip address 172.16.255.6 255.255.255.252

R3(config-if)#ip router isis cisco

R3(config-if)#exit

R3(config)#

R3(config-if)#interface Serial1/1

R3(config-if)#ip address 172.16.255.9 255.255.255.252

R3(config-if)#ip router isis cisco

R3(config-if)#isis circuit-type level-2-only

R3(config-if)#exit

R3(config)#

R3(config-if)#router isis cisco

R3(config-if)#net 49.0002.ca02.0bbc.0000.00

R3(config-if)#exit

R4(config)#interface Serial1/0

R4(config-if)#ip address 172.16.255.10 255.255.255.252

R4(config-if)#ip router isis cisco

R4(config-if)#isis circuit-type level-2-only

R4(config-if)#exit

R4(config)#

R4(config-if)#interface Serial1/1

R4(config-if)#ip address 172.16.255.13 255.255.255.252

R4(config-if)#ip router isis cisco

R4(config-if)#isis circuit-type level-1

R4(config-if)#exit

R4(config)#

R4(config-if)#router isis cisco

R4(config-if)#net 49.0003.ca03.0bbc.0000.00

R4(config)#exit

R5(config)#interface Loopback0

R5(config-if)#ip address 172.16.128.1 255.255.255.0

R5(config-if)#ip router isis cisco

R5(config-if)#isis circuit-type level-1

R5(config-if)#exit

R5(config)#

R5(config-if)#interface Loopback1

R5(config-if)#ip address 172.16.129.1 255.255.255.0

R5(config-if)#ip router isis cisco

R5(config-if)#exit

R5(config)#

R5(config-if)#interface Serial1/0

R5(config-if)#ip address 172.16.255.14 255.255.255.252

R5(config-if)#ip router isis cisco

R5(config-if)#exit

R5(config)#

R5(config-if)#router isis cisco

R5(config-if)#net 49.0003.ca04.0bbc.0000.00

R5(config-if)#is-type level-1

R5(config-if)#exit

3. Check the neighbor table of R2, R3, R4, to observe the neighbors relationship under the multi-area environment:

R2#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id

R3 L1L2 Se1/1 172.16.255.6 UP 29 01

R1 L2 Se1/0 172.16.255.1 UP 23 00

R3#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id

R2 L1L2 Se1/0 172.16.255.5 UP 25 01

R4 L2 Se1/1 172.16.255.10 UP 27 00

R3#

R4#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id

R3 L2 Se1/0 172.16.255.9 UP 23 00

R5 L1 Se1/1 172.16.255.14 UP 22 00

4. Check the routing table of R1 and R5, and observe the difference:

R1#show ip route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks

i L2 172.16.128.0/24 [115/50] via 172.16.255.2, Serial1/1

i L2 172.16.129.0/24 [115/50] via 172.16.255.2, Serial1/1

C 172.16.255.0/30 is directly connected, Serial1/1

i L2 172.16.255.4/30 [115/20] via 172.16.255.2, Serial1/1

i L2 172.16.255.8/30 [115/30] via 172.16.255.2, Serial1/1

i L2 172.16.255.12/30 [115/40] via 172.16.255.2, Serial1/1

C 172.16.1.0/24 is directly connected, Loopback0

C 172.16.2.0/24 is directly connected, Loopback1

R1#show isis database

IS-IS Level-1 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

R1.00-00 * 0x0000000B 0xD33B 679 1/0/0

IS-IS Level-2 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

R1.00-00 * 0x0000000E 0xCC4D 736 0/0/0

R2.00-00 0×00000013 0xA297 427 0/0/0

R3.00-00 0x0000000F 0x65C8 1097 0/0/0

R4.00-00 0×00000011 0x4B41 818 0/0/0

R5#show ip route

Gateway of last resort is 172.16.255.13 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

C 172.16.128.0/24 is directly connected, Loopback0

C 172.16.129.0/24 is directly connected, Loopback1

C 172.16.255.12/30 is directly connected, Serial1/0

i*L1 0.0.0.0/0 [115/10] via 172.16.255.13, Serial1/0

R5#

R5#show isis database

IS-IS Level-1 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

R4.00-00 0x0000000C 0x7BA1 770 1/0/0

R5.00-00 * 0x0000000D 0xF411 649 0/0/0

5. Use command ping to confirm route:

R1#ping 172.16.129.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.129.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 220/240/264 ms

6. In order to be able to more effectively reduce the size of the routing table, you can configure the IS-IS summary. First of all, to check the R4 routing table:

R4#show ip route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks

i L1 172.16.128.0/24 [115/20] via 172.16.255.14, Serial1/1

i L1 172.16.129.0/24 [115/20] via 172.16.255.14, Serial1/1

i L2 172.16.255.0/30 [115/30] via 172.16.255.9, Serial1/0

i L2 172.16.255.4/30 [115/20] via 172.16.255.9, Serial1/0

C 172.16.255.8/30 is directly connected, Serial1/0

C 172.16.255.12/30 is directly connected, Serial1/1

i L2 172.16.1.0/24 [115/40] via 172.16.255.9, Serial1/0

i L2 172.16.2.0/24 [115/40] via 172.16.255.9, Serial1/0

7. To configure address summary on R1:

R1(config)#router isis cisco

R1(config-router)#summary-address 172.16.0.0 255.255.128.0

R1(config-router)#exit

R1(config)#exit

8. Check routing table of R4 again:

R4#show ip route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks

i L1 172.16.128.0/24 [115/20] via 172.16.255.14, Serial1/1

i L1 172.16.129.0/24 [115/20] via 172.16.255.14, Serial1/1

i L2 172.16.255.0/30 [115/30] via 172.16.255.9, Serial1/0

i L2 172.16.255.4/30 [115/20] via 172.16.255.9, Serial1/0

C 172.16.255.8/30 is directly connected, Serial1/0

C 172.16.255.12/30 is directly connected, Serial1/1

i L2 172.16.0.0/17 [115/40] via 172.16.255.9, Serial1/0

9. To confirm the validity of routing summary:

R4#ping 172.16.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 192/225/240 ms

10. Lab completed.

Hope to helpful for you!






[Report Dead Link] Please leave a comment or send email to report dead links, so that we will update new links within 24 hours.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.