CCNP ROUTE(642-902) Lab – IPv6 OSPF Virtual Link

Ensurepass

Acme is a small export company that has an existing enterprise network that is running IPv6 OSPFv3. Currently OSPF is configured on all routers. However, R4′s loopback address (FEC0:4:4) cannot be seen in R1′s IPv6 routing table. You are tasked with identifying the cause of this fault and implementing the needed corrective actions that uses OSPF features and does no change the current area assignments. You will know that you have corrected the fault when R4′s loopback address (FEC0:4:4) can be seen in the routing table of R1.

Special Note: To gain the maximum number of points you must remove all incorrect or unneeded configuration statements related to this issue.

Answer and Explanation:

To troubleshoot the problem, first issue the show running-config on all of 4 routers. Pay more attention to the outputs of routers R2 and R3

The output of the “show running-config” command of R2:

image

The output of the “show running-config” command of P4S-R3:

image

We knew that all areas in an Open Shortest Path First (OSPF) autonomous system must be physically connected to the backbone area (Area 0). In some cases, where this is not possible,we can use a virtual link to connect to the backbone through a non-backbone area. The area through which you configure the virtual link is known as a transit area. In this case, the area 11 will become the transit area. Therefore, routers R2 and R3 must be configured with the area <area id> virtual-link <neighbor router-id> command.

+ Configure virtual link on R2 (from the first output above, we learned that the OSPF process ID of R2 is 1):

R2>enable
R2#configure terminal
R2(config)#ipv6 router ospf 1
R2(config-rtr)#area 11 virtual-link 3.3.3.3

(Notice that we have to use neighbor router-id 3.3.3.3, not R2′s router-id 2.2.2.2)
+ Configure virtual link on R3 (from the second output above, we learned that the OSPF process ID of R3 is 1 and we have to disable the wrong configuration of “area 54 virtual-link 4.4.4.4″):

R3>enable
R3#configure terminal
R3(config)#ipv6 router ospf 1
R3(config-rtr)#no area 54 virtual-link 4.4.4.4
R3(config-rtr)#area 11 virtual-link 2.2.2.2

We should check the configuration on R4:

R4>enable
R4#show running-config

You will see a wrongly configured virtual-link command. To get full mark we have to disable this command:

R4#configure terminal
R4(config)#ipv6 router ospf 1
R4(config-rtr)#no area 54 virtual-link 3.3.3.3

After finishing the configuration don’t forget to ping between R1 and R4 to make sure they work well!

Now all the configuration was done. It is weird that we can’t ping the IPv6 loopback interface of R4 (with the ping or ping ipv6 command) but we can check by using the command show ipv6 route on R1

The copying running-config startup-config command will not work but don’t worry, just skip it.

Notice: If you issue the command “show running-config” on R1, you will see these two lines:

passive-interface default

no passive-interface fa0/0 (fa0/0 is the interface connecting with R2)

These two lines make all the interfaces of R1 become passive interfaces except interface fa0/0. They are correctly configured so don’t try to disable them.





[Report Dead Link] Please leave a comment or send email to report dead links, so that we will update new links within 24 hours.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.