BCMSN Lab3 – Configuring L2 & L3 EtherChannel with LACP

Ensurepass

Objectives

1. Master the configuration methods of the Cisco-proprietary link aggregation protocol.

2. Master the differences between the Layer2 LACP configuration and the Layer3 LACP configuration.

3. LACP is the public standard link aggregation protocol.

Lab Topology

812-3

Lab Steps

1.This lab uses two Cisco Catalyst 3750 Series Switches and connects the cables of the appropriate switches according to the topology.

2. It is recommended to set the interfaces Fa1/0/1 – 22 in shutdown status in order to assure the lab of success.

3. As the working property of LACP is similar to that of PAgP, this lab only lists the configuration commands of LACP, the detailed information will be given in the lab: Configuring L2 & L3 with LAC

4. Configure the Layer2 LACP link aggregation on SW1 and SW2:

SW1(config)#interface range fastEthernet 1/0/23 – 24

SW1(config-if-range)#channel-protocol lacp

SW1(config-if-range)#channel-group 1 mode active

Creating a port-channel interface Port-channel 1

SW1(config-if-range)#exit

SW2(config)#interface range fastEthernet 1/0/23 – 24

SW2(config-if-range)#channel-protocol lacp

SW2(config-if-range)#channel-group 1 mode passive

SW2(config-if-range)#exit

5. Check the summary information of LACP on SW1 or SW2:

SW1#show etherchannel summary

Flags: D – down P – in port-channel

I – stand-alone s – suspended

H – Hot-standby (LACP only)

R – Layer3 S – Layer2

U – in use f – failed to allocate aggregator

u – unsuitable for bundling

w – waiting to be aggregated

d – default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

——+————-+———–+———————————————–

1 Po1(SU) LACP Fa1/0/23(P) Fa1/0/24(P)

SW1#

6. Configure IP address of VLAN1 on SW1 and SW2 to test , and you are recommended to use the extended ping command to test the tolerance of the aggregation link.

SW1(config)#interface vlan 1

SW1(config-if)#ip address 192.168.1.1 255.255.255.0

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#

SW2(config)#interface vlan 1

SW2(config-if)#ip address 192.168.1.2 255.255.255.0

SW2(config-if)#no shutdown

SW2(config-if)#exit

The information of the Ping command is as follows:

SW1#ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

SW1#

6. Delete the previous Layer2 LACP configurations and restart the switches

7. Configure the Layer3 LACP link aggregation on the two switches.

SW1(config)#interface port-channel 1

SW1(config-if)#no switchport

SW1(config-if)#ip address 192.168.1.1 255.255.255.0

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#

SW1(config)#interface range fastEthernet 1/0/23 – 24

SW1(config-if-range)#no switchport

SW1(config-if-range)#channel-protocol lacp

SW1(config-if-range)#channel-group 1 mode active

SW1(config-if-range)#exit

SW2(config)#interface port-channel 1

SW2(config-if)#no switchport

SW2(config-if)#ip address 192.168.1.2 255.255.255.0

SW2(config-if)#no shutdown

SW2(config-if)#exit

SW2(config)#

SW2(config)#interface range fastEthernet 1/0/23 – 24

SW2(config-if-range)#no switchport

SW2(config-if-range)#channel-protocol lacp

SW2(config-if-range)#

SW2(config-if-range)#channel-group 1 mode passive

SW2(config-if-range)#exit

SW2(config)#exit

8. Check the summary information of the aggregation link:

SW2#show etherchannel summary

Flags: D – down P – in port-channel

I – stand-alone s – suspended

H – Hot-standby (LACP only)

R – Layer3 S – Layer2

U – in use f – failed to allocate aggregator

u – unsuitable for bundling

w – waiting to be aggregated

d – default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

——+————-+———–+———————————————–

1 Po1(RU) LACP Fa1/0/23(P) Fa1/0/24(P)

SW2#

SW1#show etherchannel summary

Flags: D – down P – in port-channel

I – stand-alone s – suspended

H – Hot-standby (LACP only)

R – Layer3 S – Layer2

U – in use f – failed to allocate aggregator

u – unsuitable for bundling

w – waiting to be aggregated

d – default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

——+————-+———–+———————————————–

1 Po1(RU) LACP Fa1/0/23(P) Fa1/0/24(P)

SW1#

9. Use the ping command to test:

SW2#ping 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

SW2#

10. End.

Hope to helpful for you!





[Report Dead Link] Please leave a comment or send email to report dead links, so that we will update new links within 24 hours.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.