BCMSN Lab2 – Configuring L2 & L3 EtherChannel with PAgP

Ensurepass

Objectives

1. Master the configuration methods of the Cisco-proprietary link aggregation protocol of .

2. Master the differences between the Layer2 PAgP configuration and the Layer3 PAgP configuration.

3. PAgP is a Cisco-proprietary link aggregation protocol.

Lab Topology

812-2

Lab Steps

1.This lab uses two Cisco Catalyst 3750 Series Switches and connects the cables of the appropriate switches according to the topology.

2. It is recommended to set the interfaces Fa1/0/1 – 22 in shutdown status in order to assure the lab of success.

3. Check the STP information on SW1 and SW2

SW1#show spanning-tree

VLAN0001

Spanning tree enabled protocol ieee

Root ID Priority 32769

Address 0014.a8e2.9880

Cost 19

Port 25 (FastEthernet1/0/23)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 0014.a8f1.9880

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

—————- —- — ——— ——– ——————————–

Fa1/0/23 Root FWD 19 128.25 P2p

Fa1/0/24 Altn BLK 19 128.26 P2p

4. Although STP can avoid loops in the network, it can’t make full use of the bandwidth of the redundant links. The link aggregation protocol PAgP can be used to solve the link bandwidth problems.

5. The configurations on SW1 and SW2 are as follows:

SW1(config)#interface range fastEthernet 1/0/23 – 24

SW1(config-if-range)#switchport

SW1(config-if-range)#channel-protocol pagp

SW1(config-if-range)#channel-group 1 mode desirable

Creating a port-channel interface Port-channel 1

SW1(config-if-range)#exit

SW1(config)#exit

SW2(config)#interface range fastEthernet 1/0/23 – 24

SW2(config-if-range)#sw

SW2(config-if-range)#switchport

SW1(config-if-range)#channel-protocol pagp

SW2(config-if-range)#channel-group 1 mode auto

Creating a port-channel interface Port-channel 1

SW2(config-if-range)#exit

SW2(config)#exit

6. The interface in the Descirable mode of PAgP will actively enter the negotiation status, while in the Auto mode it will passively enter the negotiation status.

7. After configuring the two switches properly, IOS will show the following information in the process of configuration.

00:32:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

00:32:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/24, changed state to down

00:32:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

00:32:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/24, changed state to up

0:37:18: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

00:37:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

8. Check the aggregation information on the interface of SW1.

SW1#show interfaces fastEthernet 1/0/23 etherchannel

Port state = Up Mstr In-Bndl

Channel group = 1 Mode = Desirable-Sl Gcchange = 0

Port-channel = Po1 GC = 0×00010001 Pseudo port-channel = Po1

Port index = 0 Load = 0×00 Protocol = PAgP

Flags: S – Device is sending Slow hello. C – Device is in Consistent state.

A – Device is in Auto mode. P – Device learns on physical port.

d – PAgP is down.

Timers: H – Hello timer is running. Q – Quit timer is running.

S – timer is running. I – Interface timer is running.

Local information:

Hello Partner PAgP Learning Group

Port Flags State Timers Interval Count Priority Method Ifindex

Fa1/0/23 SC U6/S7 H 30s 1 128 Any 5001

Partner’s information:

Partner Partner Partner Partner Group

Port Name Device ID Port Age Flags Cap.

Fa1/0/23 SW2 0014.a8e2.9880 Fa1/0/23 20s SAC 10001

Age of the port in the current state: 00d:00h:06m:53s

SW1#

9. Use the show etherchannel port-channel command to check the aggregation group information

SW1#show etherchannel port-channel

Channel-group listing:

———————-

Group: 1

———-

Port-channels in the group:

—————————

Port-channel: Po1

————

Age of the Port-channel = 00d:00h:15m:37s

Logical slot/port = 10/1 Number of ports = 2

GC = 0×00010001 HotStandBy port = null

Port state = Port-channel Ag-Inuse

Protocol = PAgP

Ports in the Port-channel:

Index Load Port EC state No of bits

——+——+——+——————+———–

0 00 Fa1/0/23 Desirable-Sl 0

0 00 Fa1/0/24 Desirable-Sl 0

Time since last port bundled: 00d:00h:10m:27s Fa1/0/24

SW1#

10. Check the summary information of the aggregation link.

SW1#show etherchannel summary

Flags: D – down P – in port-channel

I – stand-alone s – suspended

H – Hot-standby (LACP only)

R – Layer3 S – Layer2

U – in use f – failed to allocate aggregator

u – unsuitable for bundling

w – waiting to be aggregated

d – default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

——+————-+———–+———————————————–

1 Po1(SU) PAgP Fa1/0/23(P) Fa1/0/24(P)

SW1#

11. Check the spanning-tree information.

SW1#show spanning-tree

………

Interface Role Sts Cost Prio.Nbr Type

—————- —- — ——— ——– ——————————–

Po1 Root FWD 12 128.616 P2p

SW1#

12. Configure IP addresses of VLAN1 on SW1 and SW2, test the tolerance of the aggregation link.

SW1(config)#interface vlan 1

SW1(config-if)#ip address 192.168.1.1 255.255.255.0

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW2(config)#interface vlan 1

SW2(config-if)#ip address 192.168.1.2 255.255.255.0

SW2(config-if)#no shutdown

SW2(config-if)#exit

13. Use the Ping command on R1 to test the connectivity between the two switches.

SW2#ping 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

SW2#

14. Use the extended ping command on SW2 to send ICMP data packets to SW1 continuously to test the redundant tolerance of the aggregation ports.

SW2#ping

Protocol [ip]:

Target IP address: 192.168.1.1

Repeat count [5]: 1000000

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 1000000, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

15. Manually shutdown the interface Fastethernet 1/0/24 or Fastethernet 1/0/24 of aggregation group on SW1 and observe the ping feedback information on SW2. It is found that the Ping data packets will not be interrupted, which indicates that the link aggregation can effectively avoid instability of the topology of the single link and solve the problems that link bandwidth can be used completely and achieve load balancing due to spanning tree under redundant link.

16. The previous configuration is of the Layer2 PAgP link aggregation, the following configuration will show us how to configure the Layer3 PAgP link aggregation.

17. Delete the previous Layer2 PAgP configuration.

18. Configure SW1 and SW2 as follows.

SW1(config)#interface port-channel 1

SW1(config-if)#no switchport

SW1(config-if)#ip address 192.168.1.1 255.255.255.0

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#

SW1(config)#

SW1(config)#interface range fastEthernet 1/0/23 – 24

SW1(config-if-range)#no switchport

SW1(config-if-range)#channel-protocol pagp

SW1(config-if-range)#channel-group 1 mode desirable

SW1(config-if-range)#exit

SW1(config)#exit

SW1#

00:12:15: %EC-5-L3DONTBNDL1: Fa1/0/23 suspended: PAgP not enabled on the remote port.

00:12:16: %EC-5-L3DONTBNDL1: Fa1/0/24 suspended: PAgP not enabled on the remote port.

SW2(config)#interface port-channel 1

SW2(config-if)#no switchport

SW2(config-if)#ip address 192.168.1.2 255.255.255.0

SW2(config-if)#no shutdown

SW2(config-if)#exit

SW2(config)#

SW2(config)#interface range fastEthernet 1/0/23 – 24

SW2(config-if-range)#no switchport

SW2(config-if-range)#channel-protocol pagp

SW2(config-if-range)#channel-group 1 mode desirable

SW2(config)#exit

SW2#

00:20:02: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

00:20:02: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/24, changed state to up

00:20:03: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

00:20:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

17. Check the information of the aggregation links

SW2#show etherchannel summary

Flags: D – down P – in port-channel

I – stand-alone s – suspended

H – Hot-standby (LACP only)

R – Layer3 S – Layer2

U – in use f – failed to allocate aggregator

u – unsuitable for bundling

w – waiting to be aggregated

d – default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

——+————-+———–+———————————————–

1 Po1(RU) PAgP Fa1/0/23(P) Fa1/0/24(P)

SW2#

18. Use the Ping command to test

SW2#ping 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

19. Use step14 and step15 to test the tolerance of the Layer3 PAgP aggregation link. The detailed steps will not be listed.

20. End.

Hope to helpful for you!





[Report Dead Link] Please leave a comment or send email to report dead links, so that we will update new links within 24 hours.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.